ISP============================================

no service password-encryption

hostname ISP

ip host Sydney 192.168.1.6

ip host Auckland 192.168.2.2

enable secret 5 $1$GF59$xKOFW36TwGkCvUwiPaS4w1

ip subnet-zero

ip dhcp excluded-address 10.10.0.1 10.10.0.10

ip dhcp pool ISP

network 10.10.0.0 255.255.0.0

default-router 10.10.0.1

dns-server 10.10.0.5

ip route 192.168.2.0 255.255.255.252 s0/0

ip route 172.16.4.0 255.255.255.252 s0/0

ip route 172.16.15.0 255.255.255.252 s0/0

interface FastEthernet0/0

ip address 10.10.0.1 255.255.0.0

ip nat inside

no shutdown

interface Serial0/0

bandwidth 64

ip address 192.168.1.5 255.255.255.252

ip nat outside

encapsulation frame-relay IETF

frame-relay lmi-type ansi

no shutdown

clockrate 64000

bandwidth 64

frame-relay map ip 192.168.1.6 101 broadcast IETF

interface Serial0/1

no ip address

shutdown

access-list 1 permit 10.10.0.0 0.0.255.255

ip nat pool steve 192.168.100.11 192.168.100.20 netmask 255.255.255.0

ip nat inside source list 1 pool steve overload

ip classless

ip http server

line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login

Sydney===========================================

no service password-encryption

hostname Sydney

ip host ISP 192.168.1.5

ip host Auckland 192.168.2.2

enable secret 5 $1$Gtd8$0BZ1p0RO6kNXjXpNuw0OB.

username Auckland password cisco

ip subnet-zero

interface Ethernet0

ip address 172.16.4.1 255.255.255.0

no shutdown

interface Serial0

ip address 192.168.1.6 255.255.255.252

no shutdown

encapsulation frame-relay IETF

frame-relay lmi-type ansi

bandwidth 64

frame-relay map ip 192.168.1.5 101 broadcast IETF

interface Serial1

ip address 192.168.2.1 255.255.255.252

no shutdown

encapsulation ppp

clockrate 64000

ppp authentication chap

router eigrp 100

redistribute static

network 172.16.4.0

network 192.168.2.0

network 172.16.15.0

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.5

line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login

Auckland ==============================================

no service password-encryption

hostname Auckland

ip host ISP 192.168.1.5

ip host Sydney 192.168.1.6

enable secret 5 $1$YVh5$TdlSWufohcMqSFqimwi581

username Sydney password cisco

ip route 0.0.0.0 0.0.0.0 192.168.1.5

ip subnet-zero

interface Ethernet0

ip address 172.16.15.1 255.255.255.0

no shutdown

no keepalive

interface Ethernet1

no ip address

no ip directed-broadcast

shutdown

interface Serial0

ip address 192.168.2.2 255.255.255.252

no shutdown

encapsulation ppp

ppp authentication chap

interface Serial1

no ip address

no ip directed-broadcast

shutdown

router eigrp 100

network 172.16.4.0

network 192.168.2.0

network 172.16.15.0

redistribute static

ip classless

line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login